API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Intersection Class

The Intersection class contains methods for calculating intersections between geometric objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dIntersection

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public static class Intersection

The Intersection type exposes the following members.

Methods
  NameDescription
Public methodStatic memberLineSegmentToObb
Returns a new line segment which is an intersection of the given line segment and the oriented bounding box or null if the line segment and oriented bounding box do not intersect.
Public methodStatic memberLineSegmentToPlane
Returns a new point which is an intersection of the given line segment and plane or null if the line segment and the plane are parallel or do not intersect.
Public methodStatic memberLineToLine
Returns a new line segment which is the shortest path between the given lines or null if the lines are parallel. If the resulting line segment has a length of 0.0, the given lines actually intersect in 3d space.
Public methodStatic memberLineToObb
Returns a new line segment which is an intersection of the given line and the oriented bounding box or null if the line and oriented bounding box do not intersect.
Public methodStatic memberLineToPlane
Returns a new point which is an intersection of the given line and plane or null if the line and the plane are parallel.
Public methodStatic memberPlaneToPlane
Returns a new line which is an intersection of the given two planes or null if the planes are parallel.
Top
See Also