![]() | GeometryConstants Class |
The Constants class of Geometry3d holds certain constant values that are used
internally by the other geometry classes.

Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The GeometryConstants type exposes the following members.

Name | Description | |
---|---|---|
![]() | GeometryConstants | Initializes a new instance of the GeometryConstants class |

Name | Description | |
---|---|---|
![]() ![]() | ANGULAR_EPSILON |
The minimum angle (radians) used for checking angular parallelism, perpendicularity, etc.
Anything smaller will be considered equivalent to 0.0.
|
![]() ![]() | DISTANCE_EPSILON |
The minimum distance used for checking if points, lines, etc. coincide.
Anything smaller will be considered equivalent to 0.0.
|
![]() ![]() | SCALAR_EPSILON |
The minimum value used for comparing floating point scalar values. Any smaller difference will be considered
equivalent to 0.0.
|