API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GeometricPlane Constructor (Point, Vector)

Instantiates a plane defined by the given origin point and normal vector.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public GeometricPlane(
	Point Origin,
	Vector Normal
)

Parameters

Origin
Type: Tekla.Structures.Geometry3dPoint
The origin point to be used.
Normal
Type: Tekla.Structures.Geometry3dVector
The normal vector to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.