API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrepFaceHole Class

The FacetedBrepFaceHole class defines a hole on a faceted BREP face. A FacetedBrepFaceHole cannot be instantiated directly. They are managed internally by a FacetedBrepFace. You can look also at the code example for the class FacetedBrepFace to see more examples.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dFacetedBrepFaceHole

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class FacetedBrepFaceHole

The FacetedBrepFaceHole type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the count;
Public propertyIsReadOnly
Gets a value indicating whether this instance is read only.
Public propertyVerticeIndexes
Gets the vertice indexes.
Public propertyVertices
Gets the vertices.
Top
Examples
using System.Linq;
using Tekla.Structures.Geometry3d;

public class Example
{
    public void Example1()
    {
        FacetedBrep brep = SomeFunctionThatReturnFacetedBrep();
        foreach (FacetedBrepFace face in brep.Faces.Where(x => x.HasHoles))
        {
            foreach (FacetedBrepFaceHole hole in face.Holes)
            {
                foreach (Vector vertex in hole.Vertices)
                {
                    Console.WriteLine("Hole point x:{0} y:{1} z:{2}", vertex.X, vertex.Y, vertex.Z);
                }
            }
        }
    }
}
See Also