API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrepGetInnerFace Method

Gets the inner face at the specified index.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public int[] GetInnerFace(
	int faceIndex
)

Parameters

faceIndex
Type: SystemInt32
The index of the face.

Return Value

Type: Int32
The array of vertex indexes for the inner face.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.