API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrep Constructor (Vector, Int32, IDictionaryInt32, Int32)

Initializes a new instance of the FacetedBrep class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public FacetedBrep(
	Vector[] vertices,
	int[][] outerWires,
	IDictionary<int, int[][]> innerWires
)

Parameters

vertices
Type: Tekla.Structures.Geometry3dVector
Vector of the faceted brep vertices.
outerWires
Type: SystemInt32
outerWires is an array of integer arrays, providing indices in the traversing order for each outer loop/wire. The indices correspond to the position of a vertex in the vertices array."
innerWires
Type: System.Collections.GenericIDictionaryInt32, Int32
innerWires is an array of integer arrays, providing indices in the traversing order for each inner loop/wire. The dictionary key for the innerWires is the Face index (0-origin). The indices correspond to the position of a vertex in the vertices array."
See Also