API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistancePointToPlane Method

Returns the distance between the given point and plane.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static double PointToPlane(
	Point Point,
	GeometricPlane Plane
)

Parameters

Point
Type: Tekla.Structures.Geometry3dPoint
The point to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: Double
The distance between the given point and plane.
See Also