API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DistancePointToLineSegment Method

Returns the distance between the given point and line segment.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static double PointToLineSegment(
	Point Point,
	LineSegment LineSegment
)

Parameters

Point
Type: Tekla.Structures.Geometry3dPoint
The point to be used.
LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used.

Return Value

Type: Double
The distance between the given point and line segment.
See Also