![]() | Distance Class |
The Distance class contains methods for calculating the distance between geometric objects.

Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The Distance type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | PointToLine |
Returns the distance between the given point and line.
|
![]() ![]() | PointToLineSegment |
Returns the distance between the given point and line segment.
|
![]() ![]() | PointToPlane |
Returns the distance between the given point and plane.
|
![]() ![]() | PointToPoint |
Returns the distance between the given two points.
|