API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CoordinateSystem Constructor (Point, Vector, Vector)

Instantiates a coordinate system with the given origin, X-axis and Y-axis.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public CoordinateSystem(
	Point Origin,
	Vector AxisX,
	Vector AxisY
)

Parameters

Origin
Type: Tekla.Structures.Geometry3dPoint
The origin for the coordinate system.
AxisX
Type: Tekla.Structures.Geometry3dVector
The X-axis for the coordinate system.
AxisY
Type: Tekla.Structures.Geometry3dVector
The Y-axis for the coordinate system.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.