API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CoordinateSystem Class

The CoordinateSystem class defines a coordinate system in space. The system is defined by an origin, an X-axis and a Y-axis. The Z-axis is the cross product of the X-axis and the Y-axis.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dCoordinateSystem

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class CoordinateSystem

The CoordinateSystem type exposes the following members.

Constructors
  NameDescription
Public methodCoordinateSystem
Instantiates a coordinate system in the current work plane.
Public methodCoordinateSystem(Point, Vector, Vector)
Instantiates a coordinate system with the given origin, X-axis and Y-axis.
Top
Properties
  NameDescription
Public propertyAxisX
The X-axis of the coordinate system.
Public propertyAxisY
The Y-axis of the coordinate system.
Public propertyOrigin
The origin of the coordinate system.
Top
Examples
The following example creates a new coordinate system which is used to create a new view.
using System;
using Tekla.Structures.Drawing;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Drawing GADrawing = new GADrawing();
           CoordinateSystem CoordinateSystem = new CoordinateSystem(new Point(), new Vector(1, 0, 0), new Vector(0, 1, 0));
           View newView = new View(GADrawing.GetSheet(), CoordinateSystem, CoordinateSystem, new AABB(new Point(0, 0), new Point(1000, 1000, 1000)));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.