API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AABBIsInside Method (LineSegment)

Checks if the given line segment is inside the current axis-aligned 3d bounding box.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public bool IsInside(
	LineSegment LineSegment
)

Parameters

LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be checked.

Return Value

Type: Boolean
True if the point is inside the current axis-aligned 3d bounding box.
See Also