API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AABB Constructor (Point, Point)

Instantiates a new axis-aligned 3d bounding box with the given minimum and maximum points.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public AABB(
	Point MinPoint,
	Point MaxPoint
)

Parameters

MinPoint
Type: Tekla.Structures.Geometry3dPoint
The minimum point to be used.
MaxPoint
Type: Tekla.Structures.Geometry3dPoint
The maximum point to be used.
See Also