API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PartFilterExpressionsProfile Class

The Profile class represents the profile filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering.Categories
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Profile : StringFilterExpression

The PartFilterExpressionsProfile type exposes the following members.

Constructors
  NameDescription
Public methodPartFilterExpressionsProfile
Initializes a new instance of the Profile class.
Top
Methods
  NameDescription
Top
See Also