API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PartFilterExpressionsPrimaryPart Class

The PrimaryPart class represents the primary part filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering.Categories
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PrimaryPart : StringFilterExpression

The PartFilterExpressionsPrimaryPart type exposes the following members.

Constructors
  NameDescription
Public methodPartFilterExpressionsPrimaryPart
Initializes a new instance of the PrimaryPart class.
Top
Methods
  NameDescription
Top
See Also