API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PartFilterExpressionsMaterial Class

The Material class represents the material filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering.Categories
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Material : StringFilterExpression

The PartFilterExpressionsMaterial type exposes the following members.

Constructors
  NameDescription
Public methodPartFilterExpressionsMaterial
Initializes a new instance of the Material class.
Top
Methods
  NameDescription
Top
See Also