API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ObjectFilterExpressionsIsComponent Class

The IsComponent class represents the "is component" filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering.Categories
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class IsComponent : NumericFilterExpression

The ObjectFilterExpressionsIsComponent type exposes the following members.

Constructors
  NameDescription
Public methodObjectFilterExpressionsIsComponent
Initializes a new instance of the IsComponent class.
Top
Methods
  NameDescription
Top
See Also