API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltFilterExpressionsSiteWorkshop Class

The SiteWorkshop class represents the site/workshop filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering.Categories
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class SiteWorkshop : StringFilterExpression

The BoltFilterExpressionsSiteWorkshop type exposes the following members.

Constructors
  NameDescription
Public methodBoltFilterExpressionsSiteWorkshop
Initializes a new instance of the SiteWorkshop class.
Top
Methods
  NameDescription
Top
See Also