![]() | Tekla.Structures.Filtering.Categories Namespace |
The Tekla.Structures.Filtering.Categories namespace includes all the necessary Tekla Structures filter categories for creating the filter files.

 | Class | Description |
---|---|---|
![]() | AssemblyFilterExpressions |
The AssemblyFilterExpressions class contains all the assembly filter expressions.
|
![]() | AssemblyFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | AssemblyFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | AssemblyFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | AssemblyFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | AssemblyFilterExpressionsGuid |
The Guid class represents the GUID filter expression.
|
![]() | AssemblyFilterExpressionsIdNumber |
The IdNumber class represents the identifier number filter expression.
|
![]() | AssemblyFilterExpressionsLevel |
The Level class represents the level filter expression.
|
![]() | AssemblyFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | AssemblyFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | AssemblyFilterExpressionsPositionNumber |
The PositionNumber class represents the position number filter expression.
|
![]() | AssemblyFilterExpressionsPrefix |
The Prefix class represents the prefix filter expression.
|
![]() | AssemblyFilterExpressionsSeries |
The Series class represents the series filter expression.
|
![]() | AssemblyFilterExpressionsStartNumber |
The StartNumber class represents the start number filter expression.
|
![]() | AssemblyFilterExpressionsType |
The Type class represents the type filter expression.
|
![]() | BoltFilterExpressions |
The BoltFilterExpressions class contains all the bolt filter expressions.
|
![]() | BoltFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | BoltFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | BoltFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | BoltFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | BoltFilterExpressionsLength |
The Length class represents the length filter expression.
|
![]() | BoltFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | BoltFilterExpressionsSiteWorkshop |
The SiteWorkshop class represents the site/workshop filter expression.
|
![]() | BoltFilterExpressionsSize |
The Size class represents the size filter expression.
|
![]() | BoltFilterExpressionsStandard |
The Standard class represents the standard filter expression.
|
![]() | ComponentFilterExpressions |
The ComponentFilterExpressions class contains all the component filter expressions.
|
![]() | ComponentFilterExpressionsConnectionCode |
The ConnectionCode class represents the connection code filter expression.
|
![]() | ComponentFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ComponentFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ComponentFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ComponentFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ComponentFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | ComponentFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | ComponentFilterExpressionsRunningNumber |
The RunningNumber class represents the running number filter expression.
|
![]() | ConstructionObjectFilterExpressions |
The ConstructionObjectFilterExpressions class contains all the construction object filter expressions.
|
![]() | ConstructionObjectFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ConstructionObjectFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ConstructionObjectFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ConstructionObjectFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ConstructionObjectFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | ConstructionObjectFilterExpressionsType |
The Type class represents the type filter expression.
|
![]() | LoadFilterExpressions |
The LoadFilterExpressions class contains all the load filter expressions.
|
![]() | LoadFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | LoadFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | LoadFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | LoadFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | LoadFilterExpressionsGroup |
The Group class represents the group filter expression.
|
![]() | LoadFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | LoadFilterExpressionsType |
The Type class represents the type filter expression.
|
![]() | LogicalAreaFilterExpressions |
The LogicalAreaFilterExpressions class contains all the logical area filter expressions.
|
![]() | LogicalAreaFilterExpressionsBuilding |
The Building class represents the building filter expression.
|
![]() | LogicalAreaFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | LogicalAreaFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | LogicalAreaFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | LogicalAreaFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | LogicalAreaFilterExpressionsSection |
The Section class represents the section filter expression.
|
![]() | LogicalAreaFilterExpressionsSite |
The Site class represents the site filter expression.
|
![]() | LogicalAreaFilterExpressionsStory |
The Story class represents the story filter expression.
|
![]() | ObjectFilterExpressions |
The ObjectFilterExpressions class contains all the object filter expressions.
|
![]() | ObjectFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ObjectFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ObjectFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ObjectFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ObjectFilterExpressionsGuid |
The Guid class represents the GUID filter expression.
|
![]() | ObjectFilterExpressionsIdNumber |
The IdNumber class represents the identifier number filter expression.
|
![]() | ObjectFilterExpressionsIsComponent |
The IsComponent class represents the "is component" filter expression.
|
![]() | ObjectFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | ObjectFilterExpressionsType |
The Type class represents the type filter expression.
|
![]() | ObjectTypesFilterExpressions |
The ObjectTypesFilterExpressions class contains all the object type filter expressions.
|
![]() | ObjectTypesFilterExpressionsCategoryName |
The CategoryName class represents the category name filter expression.
|
![]() | ObjectTypesFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ObjectTypesFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ObjectTypesFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ObjectTypesFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ObjectTypesFilterExpressionsEntityName |
The EntityName class represents the entity name filter expression.
|
![]() | PartFilterExpressions |
The PartFilterExpressions class contains all the part filter expressions.
|
![]() | PartFilterExpressionsClass |
The Class class represents the class filter expression.
|
![]() | PartFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | PartFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | PartFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | PartFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | PartFilterExpressionsFinish |
The Finish class represents the finish filter expression.
|
![]() | PartFilterExpressionsLot |
The Lot class represents the lot filter expression.
|
![]() | PartFilterExpressionsMaterial |
The Material class represents the material filter expression.
|
![]() | PartFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | PartFilterExpressionsNumberingSeries |
The NumberingSeries class represents the numbering series filter expression.
|
![]() | PartFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | PartFilterExpressionsPositionNumber |
The PositionNumber class represents the position number filter expression.
|
![]() | PartFilterExpressionsPourPhase |
The PourPhase class represents the pour phase filter expression.
|
![]() | PartFilterExpressionsPrefix |
The Prefix class represents the prefix filter expression.
|
![]() | PartFilterExpressionsPrimaryPart |
The PrimaryPart class represents the primary part filter expression.
|
![]() | PartFilterExpressionsProfile |
The Profile class represents the profile filter expression.
|
![]() | PartFilterExpressionsStartNumber |
The StartNumber class represents the start number filter expression.
|
![]() | PourBreakFilterExpressions |
The PourBreakFilterExpressions class contains all the pour break filter expressions.
|
![]() | PourBreakFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | PourBreakFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | PourBreakFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | PourBreakFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | PourObjectFilterExpressions |
The PourObjectFilterExpressions class contains all the pour object filter expressions.
|
![]() | PourObjectFilterExpressionsConcreteMixture |
The ConcreteMixture class represents the concrete mixture filter expression.
|
![]() | PourObjectFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | PourObjectFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | PourObjectFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | PourObjectFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | PourObjectFilterExpressionsMaterial |
The Material class represents the material filter expression.
|
![]() | PourObjectFilterExpressionsPourNumber |
The PourNumber class represents the pour number filter expression.
|
![]() | PourObjectFilterExpressionsPourPhase |
The PourPhase class represents the pour phase filter expression.
|
![]() | PourObjectFilterExpressionsPourType |
The PourType class represents the pour type filter expression.
|
![]() | PourUnitFilterExpressions |
The PourUnitFilterExpressions class contains all the pour unit filter expressions.
|
![]() | PourUnitFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | PourUnitFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | PourUnitFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | PourUnitFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | PourUnitFilterExpressionsGuid |
The Guid class represents the GUID filter expression.
|
![]() | PourUnitFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | ReferenceObjectFilterExpressions |
The ReferenceObjectFilterExpressions class contains all the reference object filter expressions.
|
![]() | ReferenceObjectFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ReferenceObjectFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ReferenceObjectFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ReferenceObjectFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ReinforcingBarFilterExpressions |
The ReinforcingBarFilterExpressions class contains all the reinforcing bar filter expressions.
|
![]() | ReinforcingBarFilterExpressionsClass |
The Class class represents the class filter expression.
|
![]() | ReinforcingBarFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | ReinforcingBarFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | ReinforcingBarFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | ReinforcingBarFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | ReinforcingBarFilterExpressionsDiameter |
The Diameter class represents the diameter filter expression.
|
![]() | ReinforcingBarFilterExpressionsJoinType |
The JoinType class represents the join type filter expression.
|
![]() | ReinforcingBarFilterExpressionsLength |
The Length class represents the length filter expression.
|
![]() | ReinforcingBarFilterExpressionsMaterial |
The Material class represents the material filter expression.
|
![]() | ReinforcingBarFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | ReinforcingBarFilterExpressionsNumberingSeries |
The NumberingSeries class represents the numbering series filter expression.
|
![]() | ReinforcingBarFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | ReinforcingBarFilterExpressionsPosition |
The Position class represents the position filter expression.
|
![]() | ReinforcingBarFilterExpressionsPositionNumber |
The PositionNumber class represents the position number filter expression.
|
![]() | ReinforcingBarFilterExpressionsPrefix |
The Prefix class represents the prefix filter expression.
|
![]() | ReinforcingBarFilterExpressionsShape |
The Shape class represents the shape filter expression.
|
![]() | ReinforcingBarFilterExpressionsSize |
The Size class represents the size filter expression.
|
![]() | ReinforcingBarFilterExpressionsStartNumber |
The StartNumber class represents the start number filter expression.
|
![]() | SurfaceFilterExpressions |
The SurfaceFilterExpressions class contains all the surface object filter expressions.
|
![]() | SurfaceFilterExpressionsClass |
The Class class represents the class filter expression.
|
![]() | SurfaceFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | SurfaceFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | SurfaceFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | SurfaceFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | SurfaceFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | SurfaceFilterExpressionsType |
The Type class represents the type filter expression.
|
![]() | TaskFilterExpressions |
The TaskFilterExpressions class contains all the task filter expressions.
|
![]() | TaskFilterExpressionsActualEndDate |
The ActualEndDate class represents the actual end date filter expression.
|
![]() | TaskFilterExpressionsActualStartDate |
The ActualStartDate class represents the actual start date filter expression.
|
![]() | TaskFilterExpressionsCompleteness |
The Completeness class represents the completeness filter expression.
|
![]() | TaskFilterExpressionsCritical |
The Critical class represents the critical filter expression.
|
![]() | TaskFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | TaskFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | TaskFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | TaskFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | TaskFilterExpressionsLocal |
The Local class represents the local filter expression.
|
![]() | TaskFilterExpressionsName |
The Name class represents the name filter expression.
|
![]() | TaskFilterExpressionsPlannedEndDate |
The PlannedEndDate class represents the planned end date filter expression.
|
![]() | TaskFilterExpressionsPlannedStartDate |
The PlannedStartDate class represents the planned start date filter expression.
|
![]() | TemplateFilterExpressions |
The TemplateFilterExpressions class contains all the template filter expressions.
|
![]() | TemplateFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | TemplateFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | TemplateFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | TemplateFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | WeldFilterExpressions |
The WeldFilterExpressions class contains all the weld filter expressions.
|
![]() | WeldFilterExpressionsCustomBoolean |
The CustomBoolean class represents a custom Boolean filter expression.
|
![]() | WeldFilterExpressionsCustomDateTime |
The CustomDateTime class represents a custom DateTime filter expression.
|
![]() | WeldFilterExpressionsCustomNumber |
The CustomNumber class represents a custom numeric filter expression.
|
![]() | WeldFilterExpressionsCustomString |
The CustomString class represents a custom string filter expression.
|
![]() | WeldFilterExpressionsPhase |
The Phase class represents the phase filter expression.
|
![]() | WeldFilterExpressionsPositionNumber |
The PositionNumber class represents the position number filter expression.
|
![]() | WeldFilterExpressionsReferenceText |
The ReferenceText class represents the reference text filter expression.
|
![]() | WeldFilterExpressionsSizeAboveLine |
The SizeAboveLine class represents the size above line filter expression.
|
![]() | WeldFilterExpressionsSizeBelowLine |
The SizeBelowLine class represents the size below line filter expression.
|
![]() | WeldFilterExpressionsTypeAboveLine |
The TypeAboveLine class represents the type above line filter expression.
|
![]() | WeldFilterExpressionsTypeBelowLine |
The TypeBelowLine class represents the type below line filter expression.
|
![]() | WeldFilterExpressionsWeldingSite |
The WeldingSite class represents the welding site filter expression.
|