API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StringOperatorType Enumeration

The string operator type defines the operators between two string filter expressions.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public enum StringOperatorType
Members
  Member nameValueDescription
IS_EQUAL1 The "is equal" operator.
IS_NOT_EQUAL2 The "is not equal" operator.
CONTAINS9 The "contains" string operator.
NOT_CONTAINS10 The "not contains" string operator.
STARTS_WITH11 The "starts with" string operator.
NOT_STARTS_WITH12 The "not starts with" string operator.
ENDS_WITH13 The "ends with" string operator.
NOT_ENDS_WITH14 The "not ends with" string operator.
See Also