![]() | InvalidFilterExpressionException Class |
The InvalidFilterExpressionException class represents an error that occurred during the expression evaluation.
This class cannot be inherited.

Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The InvalidFilterExpressionException type exposes the following members.

Name | Description | |
---|---|---|
![]() | InvalidFilterExpressionException(Expression, InvalidFilterExpressionExceptionReasonsType) |
Initializes a new instance of the InvalidFilterExpressionException class.
|
![]() | InvalidFilterExpressionException(Expression, InvalidFilterExpressionExceptionReasonsType, Int32) |
Initializes a new instance of the InvalidFilterExpressionException class.
|
![]() | InvalidFilterExpressionException(Expression, OperatorType, Expression, InvalidFilterExpressionExceptionReasonsType) |
Initializes a new instance of the InvalidFilterExpressionException class.
|

Name | Description | |
---|---|---|
![]() | Expression |
Gets the invalid expression.
|
![]() | InvalidFilterExpressionExceptionReasonsType |
Gets the reason why the exception is thrown.
|
![]() | LeftExpression |
Gets the invalid expression's left operand.
|
![]() | OperatorType |
Gets the invalid expression's operator.
|
![]() | RightExpression |
Gets the invalid expression's right operand.
|