API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FilterExpression Class

The FilterExpression class represents a filter expression. This is a base class for other filter expressions and should not be used directly.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public abstract class FilterExpression : Expression

The FilterExpression type exposes the following members.

Properties
  NameDescription
Public propertyIsEnable
Gets or sets the enabled state of the filter expression.
Top
Methods
  NameDescription
Top
See Also