API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Filter Constructor (String, IFormatProvider)

Initializes a new instance of the Filter class.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Filter(
	string FullFileName,
	IFormatProvider Provider = null
)

Parameters

FullFileName
Type: SystemString
The filter's full file name to load.
Provider (Optional)
Type: SystemIFormatProvider
An object that supports the IFormatProvider interface to correctly parse numbers and dates according to the current culture information. If not provided, the current CultureInfo is used.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when a null FullFileName is specified.
See Also