API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BooleanConstantFilterExpression Class

The BooleanConstantFilterExpression class represents a constant Boolean filter expression.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class BooleanConstantFilterExpression : DataFilterExpression

The BooleanConstantFilterExpression type exposes the following members.

Constructors
  NameDescription
Public methodBooleanConstantFilterExpression(Boolean)
Initializes a new instance of the BooleanConstantFilterExpression class.
Public methodBooleanConstantFilterExpression(Boolean, IFormatProvider)
Initializes a new instance of the BooleanConstantFilterExpression class.
Top
Methods
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.