API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BinaryFilterExpressionCollectionInsert Method

Inserts an element in the collection at a specified index.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public void Insert(
	int Index,
	BinaryFilterExpressionItem Item
)

Parameters

Index
Type: SystemInt32
The zero-based index at which the item shoud be inserted.
Item
Type: Tekla.Structures.FilteringBinaryFilterExpressionItem
The item to insert. This value cannot be null.

Implements

IListTInsert(Int32, T)
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the supplied item is null.
ArgumentExceptionThrown when the supplied index is out of bounds.
See Also