![]() | BinaryFilterExpression Constructor (NumericFilterExpression, NumericOperatorType, NumericConstantFilterExpression) |
Initializes a new instance of the BinaryFilterExpression class.
Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

public BinaryFilterExpression( NumericFilterExpression Left, NumericOperatorType Oper, NumericConstantFilterExpression Right )
Parameters
- Left
- Type: Tekla.Structures.FilteringNumericFilterExpression
The left operand of the filter expression. - Oper
- Type: Tekla.Structures.FilteringNumericOperatorType
The operator of the filter expression. - Right
- Type: Tekla.Structures.FilteringNumericConstantFilterExpression
The right operand of the filter expression.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when a null filter expression is specified. |