![]() | BinaryFilterExpression Constructor (DateTimeFilterExpression, DateTimeOperatorType, DateTimeConstantFilterExpression) |
Initializes a new instance of the BinaryFilterExpression class.
Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

public BinaryFilterExpression( DateTimeFilterExpression Left, DateTimeOperatorType Oper, DateTimeConstantFilterExpression Right )
Parameters
- Left
- Type: Tekla.Structures.FilteringDateTimeFilterExpression
The left operand of the filter expression. - Oper
- Type: Tekla.Structures.FilteringDateTimeOperatorType
The operator of the filter expression. - Right
- Type: Tekla.Structures.FilteringDateTimeConstantFilterExpression
The right operand of the filter expression.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when a null filter expression is specified. |