API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BinaryFilterExpression Constructor (BooleanFilterExpression, BooleanOperatorType, BooleanConstantFilterExpression)

Initializes a new instance of the BinaryFilterExpression class.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public BinaryFilterExpression(
	BooleanFilterExpression Left,
	BooleanOperatorType Oper,
	BooleanConstantFilterExpression Right
)

Parameters

Left
Type: Tekla.Structures.FilteringBooleanFilterExpression
The left operand of the filter expression.
Oper
Type: Tekla.Structures.FilteringBooleanOperatorType
The operator of the filter expression.
Right
Type: Tekla.Structures.FilteringBooleanConstantFilterExpression
The right operand of the filter expression.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when a null filter expression is specified.
See Also