API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickThreePoints Method

Requests a pick of three points from the user.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public void PickThreePoints(
	string firstPrompt,
	string secondPrompt,
	string thirdPrompt,
	out Point firstPickedPoint,
	out Point secondPickedPoint,
	out Point thirdPickedPoint,
	out ViewBase pickedView
)

Parameters

firstPrompt
Type: SystemString
The prompt shown in the status bar before the first pick. See the class remarks for more information about prompts.
secondPrompt
Type: SystemString
The prompt shown in the status bar before the second pick. See the class remarks for more information about prompts.
thirdPrompt
Type: SystemString
The prompt shown in the status bar before the third pick. See the class remarks for more information about prompts.
firstPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The first picked point in the view coordinates.
secondPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The second picked point in the view coordinates.
thirdPickedPoint
Type: Tekla.Structures.Geometry3dPoint
The third picked point in the view coordinates.
pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also