API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoints Method (StringList, PointList, ViewBase)

Requests picks of points from the user. The sequence is terminated by the middle button pick.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public void PickPoints(
	StringList prompts,
	out PointList pickedPoints,
	out ViewBase pickedView
)

Parameters

prompts
Type: Tekla.Structures.DrawingStringList
The prompts shown in the status bar before the picks. See the class remarks for more information about prompts.
pickedPoints
Type: Tekla.Structures.DrawingPointList
The picked points in the view coordinates.
pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also