![]() | PickerPickPoints Method (StringList) |
Requests picks of points from the user. The sequence is terminated by the middle button pick.
Returns the picked points in the view coordinates and the view in which the pick occurred.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

Parameters
- prompts
- Type: Tekla.Structures.DrawingStringList
The prompts shown in the status bar before the picks. See the class remarks for more information about prompts.
Return Value
Type: TuplePointList, ViewBase[Missing <returns> documentation for "M:Tekla.Structures.Drawing.UI.Picker.PickPoints(Tekla.Structures.Drawing.StringList)"]

Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |