![]() | PickerPickPoint Method (String) |
Requests the user to pick one point.
Returns the picked point in the view coordinates and the view in which the pick occurred.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

Parameters
- prompt
- Type: SystemString
The prompt shown in the status bar. See the class remarks for more information about prompts.
Return Value
Type: TuplePoint, ViewBase[Missing <returns> documentation for "M:Tekla.Structures.Drawing.UI.Picker.PickPoint(System.String)"]

Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |