![]() | PickerPickObjectAndPoint Method |
Requests the user to pick one object.
Returns the picked drawing object, the view in which the pick occurred and picked point in the view coordinates.
Namespace: Tekla.Structures.Drawing.UI
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

Parameters
- prompt
- Type: SystemString
The prompt shown in the status bar before the pick. See the class remarks for more information about prompts.
Return Value
Type: TupleDrawingObject, ViewBase, Point[Missing <returns> documentation for "M:Tekla.Structures.Drawing.UI.Picker.PickObjectAndPoint(System.String)"]

Exception | Condition |
---|---|
InvalidPluginPickerInputException | Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined. |
PickerInterruptedException | Thrown when the user interrupts the picker before anything has been picked. |