API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingObjectSelectorGetSelected Method

Gets the selected objects in the drawing.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingObjectEnumerator GetSelected()

Return Value

Type: DrawingObjectEnumerator
A drawing object enumerator of the selected objects in the drawing.
See Also