API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputDefinitionFactoryGetView Method

Gets the view that the given input belongs to.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static ViewBase GetView(
	DrawingPluginBaseInputDefinition input
)

Parameters

input
Type: Tekla.Structures.PluginsDrawingPluginBaseInputDefinition
The input.

Return Value

Type: ViewBase
The view.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.