API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputDefinitionFactoryCreateInputDefinition Method (ViewBase, Point, Point)

Creates a two-point input definition.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static DrawingPluginBaseInputDefinition CreateInputDefinition(
	ViewBase view,
	Point point1,
	Point point2
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used in the input.
point1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used in the input.
point2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used in the input.

Return Value

Type: DrawingPluginBaseInputDefinition
The input definition.
See Also