API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InputDefinitionFactoryCreateInputDefinition Method (ViewBase, PointList)

Creates a multi-point input definition.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static DrawingPluginBaseInputDefinition CreateInputDefinition(
	ViewBase view,
	PointList points
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used in the input.
points
Type: Tekla.Structures.DrawingPointList
The points to be used in the input.

Return Value

Type: DrawingPluginBaseInputDefinition
The input definition.
See Also