API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingCoordinateConverterConvert Method (ViewBase, ViewBase, Point)

Converts one coordinate point from one view's coordinate system to another view's coordinate system.

Namespace:  Tekla.Structures.Drawing.Tools
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static Point Convert(
	ViewBase fromView,
	ViewBase toView,
	Point point
)

Parameters

fromView
Type: Tekla.Structures.DrawingViewBase
The source view.
toView
Type: Tekla.Structures.DrawingViewBase
The target view.
point
Type: Tekla.Structures.Geometry3dPoint
The point to be converted.

Return Value

Type: Point
The converted point.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.