API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingCreatorCreateDrawings Method (AutoDrawingRule, Identifier)

Creates drawings using the AutoDrawing tool of Tekla Structures.

Namespace:  Tekla.Structures.Drawing.Automation
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static bool CreateDrawings(
	AutoDrawingRule Rule,
	Identifier ModelObjectIdentifier
)

Parameters

Rule
Type: Tekla.Structures.Drawing.AutomationAutoDrawingRule
The AutoDrawing rule to be used.
ModelObjectIdentifier
Type: Tekla.StructuresIdentifier
The model object identifier to be used. Part identifier to create single part drawing or assembly identifier to create assembly drawing.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.