API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AutoDrawingsStatusEnum Enumeration

The status of the AutoDrawing script execution.

Namespace:  Tekla.Structures.Drawing.Automation
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum AutoDrawingsStatusEnum
Members
  Member nameValueDescription
OPERATION_OK0 The AutoDrawing script was executed without errors.
OPERATION_FAILED1 An error occured during the AutoDrawing script execution. See the AutoDrawing log file for more details.
ERROR_NUMBERING_NOT_UPTODATE2 The AutoDrawing script could not be executed because the numbering was not up-to-date.
ERROR_DRAWING_EDITOR_MUST_BE_CLOSED3 The command could not be executed because a drawing was open. Close the drawing and try again.
See Also