API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewMarkBasicTagAttributes Constructor (Vector, TagLocation, ContainerElement)

Creates a new mark tag attributes instance with the given offset, location and content.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public ViewMarkBasicTagAttributes(
	Vector offset,
	TagLocation location,
	ContainerElement tagContent
)

Parameters

offset
Type: Tekla.Structures.Geometry3dVector
The offset of the mark tag to be used.
location
Type: Tekla.Structures.DrawingTagLocation
The location of the mark tag to be used.
tagContent
Type: Tekla.Structures.DrawingContainerElement
The content of the mark tag to be used.
See Also