API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewMarkBasicSymbolAttributes Constructor (Double, MarkSymbolShape)

Creates a new mark symbol attributes instance with the given size and shape.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public ViewMarkBasicSymbolAttributes(
	double size,
	MarkSymbolShape shape
)

Parameters

size
Type: SystemDouble
The size of the mark symbol to be used.
shape
Type: Tekla.Structures.DrawingMarkSymbolShape
The shape of the mark symbol to be used.
See Also