API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewBaseGetObjects Method

Gets the objects in the view. Does not return child objects (single dimensions, grid lines, views).

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingObjectEnumerator GetObjects()

Return Value

Type: DrawingObjectEnumerator
The objects in the view.

Implements

IHasChildrenGetObjects
See Also