API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewViewTypes Enumeration

The possible types of views.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum ViewTypes
Members
  Member nameValueDescription
UnknownViewType0 The view type is not known.
FrontView1 Front side view of the part.
TopView2 Top side view of the part.
BackView3 Back side view of the part.
BottomView4 Bottom side view of the part.
EndView5 End side view of the part.
SectionView6 Section view of the part.
ModelView7 Model view of the part.
DetailView8 Detail view of the part.
_3DView9 3d view of the part.
See Also