![]() | ViewViewMarkTagAttributes Class |
The ViewMarkTagAttributes class contains attributes for view mark tags.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingViewViewMarkTagAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicTagAttributes
Tekla.Structures.DrawingViewViewMarkTagAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ViewViewMarkTagAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ViewViewMarkTagAttributes |
Creates a new mark tag attributes instance.
|
![]() | ViewViewMarkTagAttributes(Vector, TagLocation, TextAlignment, ContainerElement) |
Creates a new mark tag attributes instance with the given offset, location, alignment and content.
|

Name | Description | |
---|---|---|
![]() | Location |
The location of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.) |
![]() | Offset |
The offset of the mark tag.
(Inherited from ViewMarkBasicTagAttributes.) |
![]() | TagAlignment |
The tag text alignment.
|
![]() | TagContent |
The tag content.
(Inherited from ViewMarkBasicTagAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides ViewMarkBasicTagAttributesIsEqual(Object).) |