API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewViewMarkSymbolAttributes Constructor (Double, MarkSymbolShape, ViewLabelLineLengthType, Double)

Creates a new mark symbol attributes instance with the given size, shape, line length type and line length.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public ViewMarkSymbolAttributes(
	double size,
	MarkSymbolShape shape,
	ViewLabelLineLengthType lineLengthType,
	double lineLength
)

Parameters

size
Type: SystemDouble
The size of the mark symbol to be used.
shape
Type: Tekla.Structures.DrawingMarkSymbolShape
The shape of the mark symbol to be used.
lineLengthType
Type: Tekla.Structures.DrawingViewLabelLineLengthType
The line length type of the mark symbol to be used.
lineLength
Type: SystemDouble
The line length of the mark symbol to be used.
See Also