![]() | ViewViewMarkSymbolAttributes Class |
The ViewMarkSymbolAttributes class contains symbol attributes for view mark tags.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicSymbolAttributes
Tekla.Structures.DrawingViewViewMarkSymbolAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingViewMarkBasicSymbolAttributes
Tekla.Structures.DrawingViewViewMarkSymbolAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ViewViewMarkSymbolAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ViewViewMarkSymbolAttributes |
Creates a new mark symbol attributes instance.
|
![]() | ViewViewMarkSymbolAttributes(Double, MarkSymbolShape, ViewLabelLineLengthType, Double) |
Creates a new mark symbol attributes instance with the given size, shape, line length type and line length.
|

Name | Description | |
---|---|---|
![]() | LineLength |
The label line length in the case of custom length.
|
![]() | LineLengthType |
The label line length type.
|
![]() | Shape |
The shape of the mark symbol.
(Inherited from ViewMarkBasicSymbolAttributes.) |
![]() | Size |
The size of the mark symbol.
(Inherited from ViewMarkBasicSymbolAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides ViewMarkBasicSymbolAttributesIsEqual(Object).) |