![]() | ViewViewAttributes Class |
The ViewAttributes class contains the attributes for the view.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ViewViewAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | ViewViewAttributes |
Creates a new view attributes instance that loads standard attributes.
|
![]() | ViewViewAttributes(String) |
Creates a new view attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | DatumLevel |
The specified datum level.
If ViewPlaneDatumPointForElevations is set to true when DatumLevel is set,
the value of ViewPlaneDatumPointForElevations will change to false.
|
![]() | FixedViewPlacing |
Defines whether the view placing is fixed (true) or free (false).
|
![]() | LabelPositionHorizontal |
The horizontal position of the view label.
|
![]() | LabelPositionVertical |
The vertical position of the view label.
|
![]() | LocationBy |
Gets or sets the location by attribute.
Value is ViewAttributes.LocationByModelOrigin, ViewAttributes.LocationByProjectBasePoint or guid of a Basepoint.
|
![]() | MarkSymbolAttributes |
The view mark symbol attributes.
|
![]() | MarkSymbolColor |
The view mark symbol color.
|
![]() | PartialProfileLength |
Gets or sets the partial profile length.
|
![]() | PartialProfileOffset |
Gets or sets the partial profile offset
|
![]() | PourView |
Defines whether the view is pour view or not.
|
![]() | ReflectedView |
Defines whether the view is reflected or not.
|
![]() | Scale |
The view scale.
|
![]() | Shortening |
Gets or sets the shortening attributes for the view.
|
![]() | ShowPartOpeningsOrRecessSymbol |
Defines whether to show the openings/recess symbol or not.
|
![]() | TagsAttributes |
The attributes for view mark tags.
|
![]() | UndeformedView |
Defines whether the view is undeformed or not.
|
![]() | UnfoldedView |
Defines whether the view is unfolded or not.
|
![]() | ViewExtensionForNeighbourParts |
The view extension for neighbour parts.
|
![]() | ViewPlaneDatumPointForElevations |
Defines whether the datum point for elevations is view plane based (true) or specified (false).
When set to false, the value of DatumLevel is used.
When set to true, DatumLevel will be set to 0.0.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |

Name | Description | |
---|---|---|
![]() ![]() | LocationByModelOrigin |
A constant string defining that the view location is calculated by model origin.
|
![]() ![]() | LocationByProjectBasePoint |
A constant string defining that the view location is calculated by project base point.
|