API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewRotateViewOnDrawingPlane Method

Rotate the view on the drawings plane. This works just like the user interface command "Rotate view".

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool RotateViewOnDrawingPlane(
	double rotationAngle
)

Parameters

rotationAngle
Type: SystemDouble
The amount of degrees to rotate the view with.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tekla.Structures.Drawing.View.RotateViewOnDrawingPlane(System.Double)"]

See Also