API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

View Constructor (ContainerView, CoordinateSystem, CoordinateSystem, ArrayList)

Creates a new view instance with the given coordinate systems and part list.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public View(
	ContainerView View,
	CoordinateSystem ViewCoordinateSystem,
	CoordinateSystem DisplayCoordinateSystem,
	ArrayList PartList
)

Parameters

View
Type: Tekla.Structures.DrawingContainerView
The container view where the view is placed.
ViewCoordinateSystem
Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the view restriction box.
DisplayCoordinateSystem
Type: Tekla.Structures.Geometry3dCoordinateSystem
The coordinate system of the display plane.
PartList
Type: System.CollectionsArrayList
An array list of identifiers of model objects to be shown in the view.
See Also